Safari bugs

I have now been using Mac OS X Tiger 10.4 for a few days. I will probably post some kind of review one of those days, but it the meantime, I have discovered a strange bug with Safari.
The side-bar and the title of my blog have a semi-transparent blue PNG file as background. Previous versions of safari, and the Camino web browser displayed it correctly, i.e. the display was something like this (screenshot done using Camino 0.8.2).

Screenshot of this blog displayed using Camino 0.82

Curiously the version of Safari 2.0 (412) that comes with Tiger displays it differently.

Screenshot of this blog displayed using safari 2.o (412)

Could readers, in particular the ones that also use Safari confirm this bug? Basically it boils down to a simple question: what color is this box? background sample

I also found another bug, Safari cannot handle quicktime movies whose name contains japanese characters. I build a small page that crashes Safari, please do not follow this link if you are not sure of what you are doing. I have submitted this one to Apple, we will see how they react.

3 thoughts on “Safari bugs

  1. J’ai le meme problème que toi…. Mais gris c’est bien aussi ;-)

  2. I tested the latest Safari WebCore (following this hint) and it’s still gray.

    Firefox 1.04 on Windows displays it all blue and fine; IE 6 displays it blue, but chokes on the transparency.

  3. Tiens, je viens de penser à vérifier sous Konqueror : les couleurs et la transparence sont bien la. Par contre le son de la petite cascade en dessus le fait crasher lamentablement.

Leave a Reply to Alias Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.